HappyRobot

Google Cloud outage causing failures in related services
Resolved·Partial outage

All systems and metrics have returned to normal, but we are continuing to closely monitor to ensure ongoing stability and performance.

Thu, Jun 12, 2025, 09:38 PM
(2 weeks ago)
·
Affected components
Platform
Updates

Resolved

All systems and metrics have returned to normal, but we are continuing to closely monitor to ensure ongoing stability and performance.

Thu, Jun 12, 2025, 09:38 PM

Monitoring

The impact of the Google Cloud outage has reduced, and many systems have recovered. We are actively monitoring all systems to ensure everything remains fully operational. We will continue to provide updates as necessary.

Thu, Jun 12, 2025, 07:28 PM(2 hours earlier)

Investigating

There is a google cloud outage going on. This is causing failures in multiple services related to gmail, recordings and google sheets.

We will continue to monitor and provide regular updates.

Thu, Jun 12, 2025, 06:24 PM(1 hour earlier)
Powered by