HappyRobot

Partial Outage Affecting Inboud Calls for +34 numbers
Resolved·Degraded performance

The issue affecting inbound calls from network subscribers to a subset of Twilio's Spain phone numbers has been resolved, and the service is functioning normally at this time.

Thu, Jan 22, 2026, 06:34 PM
(1 week ago)
·
Affected components
Platform
Updates

Resolved

The issue affecting inbound calls from network subscribers to a subset of Twilio's Spain phone numbers has been resolved, and the service is functioning normally at this time.

Thu, Jan 22, 2026, 06:34 PM

Identified

We are currently seeing impact on the Inbound calls not able to connect for the +34 numbers. This is result of ongoing outage from Twilio. We are monitoring the situation and will provide an update soon.

Link : https://status.twilio.com/

Thu, Jan 22, 2026, 12:43 PM(5 hours earlier)
Powered by