The Platform UI is back to operational.
Resolved
Monitoring
The issue was identified and it is fixed now.We are monitoring now.
Investigating
The Platform page is currently down. Calls and Text services are up.