Resolved
Analytics Page is back up
Monitoring
The analytics page is unavailable. We are investigating.
Monitoring
Incident has been solved, we are closely monitoring the platform
Identified
Partial Outage
Identified
We are experiencing latency issues with our calls and are currently investigating the cause